返回首页
当前位置: 网站首页>>协议大全>>NAT协议>>

PPPoE + NAT设置

时间:2008-09-10 来源: 作者: 点击:
电信最近力推的ADSL是一种性能价格比较好的Internet接入方式,适用于只需访问Internet,不需要对外提供服务(如 WWW, Mail等)的场合。ADSL最常见的应用方式是用一台安装了PPPoE客户端软件的PC来拔号作代理服务器,让多台主机同时访问Internet。有的时候该PC的任务也可以
  

电信最近力推的ADSL是一种性能价格比较好的Internet接入方式,适用于只需访问Internet,不需要对外提供服务(如 WWW, Mail等)的场合。ADSL最常见的应用方式是用一台安装了PPPoE客户端软件的PC来拔号作代理服务器,让多台主机同时访问Internet。有的时候该PC的任务也可以用路由器来完成,最低档的2514路由器就能胜任,只要路由器有两个以太端网口即可。当然,还需要有适当的IOS软件,同时支持PPPoE Client和NAT两个特性、需求最低的IOS是“REMOTE ACCESS SERVER”特性集。以2621为例,运行该IOS只需32M内存、8M Flash,文件名为:c2600-c-mz.122-4.T1.bin ,这就是下面配置的运行环境。
  实际运行的配置:
  version 12.2
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname 2621
  !
  enable secret 5 $1$LJV3$jqSDKFMSZiQBAjlnN/
  !
  ip subnet-zero
  ip name-server 202.xxx.xxx.xxx
  !
  vpdn enable
  !
  vpdn-group PPPoE
  request-dialin
  protocol pppoe
  !
  interface FastEthernet0/0
  ip address 10.1.1.1 255.255.255.0
  ip nat inside
  duplex auto
  speed auto
  !
  interface FastEthernet0/1
  no ip address
  speed 10
  half-duplex
  pppoe enable
  pppoe-client dial-pool-number 1
  !
  interface Dialer1
  mtu 1492
  ip address negotiated
  ip nat outside
  encapsulation ppp
   no ip mroute-cache
  dialer pool 1
  dialer-group 1
  no cdp enable
  ppp authentication pap callin
  ppp pap sent-username abc123@163 password 7 **********
  !
  ip nat inside source list 1 interface Dialer1 overload
  ip classless
  ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
  no ip http server
  ip pim bidir-enable
  !
  access-list 1 permit any
  dialer-list 1 protocol ip permit
  !
  line con 0
  line aux 0
  line vty 0 4
  password *****
  login
  !
  end
  在下行速度为2M的ADSL线路上,F0/0上接只一台PC,用蚂蚁下载测试时,峰值速度竟超过300K,不知道是不是蚂蚁有点夸大了。:-) 值得注意的是有的地区需要用chap认证方式,这时相应的指令为:
  ppp authentication chap callin
  ppp chap hostname abc123@163
  ppp chap password **********
  相关调试命令:
 

最近还碰到一个现象,一个网络中VTP Server 是6509,下面的VTP Client交换机有35xx和2924,由于29xx最大同时只能支持64个VLAN,所以当6509上定义的VLAN超过了64个之后,与6509直接相连的2924不能学习到新加的VLAN,但原有VLAN工作正常;而经过35xx连接6509的2924交换机则出现了自动从VTP Client模式转成Transparent模式的现象,除VLAN1之外不通,需要重新启动才能正常工作。如果这些2924交换机上的端口需要加入新增的VLAN,则需要手工修改其上的VLAN定义,删去一些旧的VLAN,增加新的VLAN。

------分隔线----------------------------
顶一下
(1)
100%
踩一下
(0)
0%
------分隔线----------------------------
最新评论 查看所有评论
发表评论 查看所有评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 密码: 验证码:
推荐内容
  • 组建NAT服务器组

    基于NAT的网络规划曾经有一个朋友问我,他们单位有一个100台机器的大机房,要实现每一...

  • PPPoE + NAT设置

    电信最近力推的ADSL是一种性能价格比较好的Internet接入方式,适用于只需访问Internet...

  • 在cisco2621路由器上配置NAT

    Router#sh run Building configuration... Current configuration: ! version 12.0 se...

  • cisco设备配置NAT

    ! version 12.0 service timestamps debug uptime service timestamps log uptime no ...

  • IPsec与NAT共存

    现在,网络安全和网络地址转换的应用已经十分广泛。单就其中任何一种技术来说,都是很...

  • NAT协议的原理

    IP地址耗尽促成了CIDR的开发,但CIDR开发的主要目的是为了有效的使用现有的internet地...