返回首页

思科路由器EIGRP基本设置

时间:2005-11-16 来源: 作者: 点击:
eigrp基本设置与igrp完成一致。启动eigrp路由协议,在全局设置模式下, router eigrp 自治域号 同一自治域内的路由器才能交换路由信息本路由器参加动态路由的子网 network 子网号 eigrp只是将由network指定的子网在各端口中进行传递以交换路由信息,如果不指定子网,则
  eigrp基本设置与igrp完成一致。启动eigrp路由协议,在全局设置模式下,
  
  router eigrp 自治域号
  
  同一自治域内的路由器才能交换路由信息本路由器参加动态路由的子网
  
  network 子网号
  
  eigrp只是将由network指定的子网在各端口中进行传递以交换路由信息,如果不指定子网,则路由器不会将该子网广播给其它路由器。
  
  指定某路由器所知的eigrp路由信息广播给那些与其邻接的路由器neighbor 邻接路由器的相邻端口地址。
  
  
  
  实例
  
  2511-1的设置
  
  Current configuration :
  
  !
  
  version 11.3
  
  no service password-encryption
  
  !
  
  hostname 2511-1
  
  !
  
  enable password cisco
  
  !
  
  !
  
  interface Ethernet0
  
  ip address 192.4.1.1 255.255.255.0
  
  !
  
  interface Serial0
  
  ip address 192.3.1.1 255.255.255.0
  
  encapsulation frame-relay IETF
  
  no ip mroute-cache
  
  bandwidth 2000
  
  frame-relay map ip 192.3.1.2 100 broadcast
  
  frame-relay lmi-type cisco
  
  !
  
  interface Serial1
  
  ip address 192.1.1.1 255.255.255.0
  
  encapsulation ppp
  
  bandwidth 64
  
  !
  
  router eigrp 10
  
  passive-interface Ethernet0
  
  network 192.1.1.0 255.255.255.0
  
  network 192.3.1.0 255.255.255.0
  
  network 192.4.1.0 255.255.255.0
  
  neighbor 192.1.1.2
  
  neighbor 192.3.1.2
  
  !
  
  ip classless
  
  !
  
  line con 0
  
  line 1 8
  
  line aux 0
  
  line vty 0 4
  
  login
  
  !
  
  end
  
   
  
  2505的设置
  
  Current configuration :
  
  version 11.2
  
  no service udp-small-servers
  
  no service tcp-small-servers
  
  !
  
  hostname 2505
  
  !
  
  enable secret 5 $1$GbyT$OR05giiLx14hEAO0F8kV1
  
  !
  
  hub ether 0 1
  
  link-test
  
  auto-polarity
  
  !
  
  hub ether 0 2
  
  link-test
  
  auto-polarity
  
  !
  
  hub ether 0 3
  
  link-test
  
  auto-polarity
  
  !
  
  hub ether 0 4
  
  link-test
  
  auto-polarity
  
  !
  
  hub ether 0 5
  
  link-test
  
  auto-polarity
  
  !
  
  hub ether 0 6
  
  link-test
  
  auto-polarity
  
  !
  
  hub ether 0 7
  
  link-test
  
  auto-polarity
  
  !
  
  hub ether 0 8
  
  link-test
  
  auto-polarity
  
  !
  
  interface Ethernet0
  
  ip address 192.1.4.1 255.255.255.0
  
  !
  
  interface Serial0
  
  ip address 192.1.2.1 255.255.255.0
  
  bandwidth 2000
  
  clockrate 2000000
  
  !
  
  interface Serial1
  
  ip address 192.1.1.2 255.255.255.0
  
  enpsuration ppp
  
  bandwidth 64
  
  clockrate 64000
  
  !
  
  router eigrp 10
  
  passive-interface Ethernet0
  
  network 192.1.1.0 255.255.255.0
  
  network 192.1.2.0 255.255.255.0
  
  network 192.1.4.0 255.255.255.0
  
  neighbor 192.1.1.1
  
  neighbor 192.1.2.2
  
  !
  
  no ip classless
  
  !
  
  line con 0
  
  line aux 0
  
  line vty 0 4
  
  login
  
  !
  
  end
  
  internal -2的设置
  
  Current configuration :
  
  !
  
  version 11.2
  
  no service udp-small-servers
  
  no service tcp-small-servers
  
  !
  
  hostname internal-2
  
  !
  
  enable secret 5 $1$KX00$rT1/2TvDokWxT4xC6wvmi/
  
  !
  
  interface Ethernet0
  
  no ip address
  
  shutdown
  
  !
  
  interface Serial0
  
  ip address 192.1.2.2 255.255.255.0
  
  !
  
  interface Serial1
  
  no ip address
  
  shutdown
  
  !
  
  router eigrp 10
  
  network 192.1.2.0 255.255.255.0
  
  neighbor 192.1.2.1
  
  !
  
  no ip classless
  
  !
  
  line con 0
  
  line 1 16
  
  line aux 0
  
  line vty 0 4
  
  login
  
  !
  
  end
  
   
  
   
  
  2514的设置
  
  Current configuration :
  
  !
  
  version 11.2
  
  no service udp-small-servers
  
  no service tcp-small-servers
  
  !
  
  hostname 2514
  
  !
  
  enable secret 5 $1$uoHU$Vks/lY CRi33z4TXs4qekI0
  
  !
  
  frame-relay switching
  
  !
  
  interface Ethernet0
  
  ip address 192.5.1.1 255.255.255.0
  
  !
  
  interface Ethernet1
  
  no ip address
  
  shutdown
  
  !
  
  interface Serial0
  
  ip address 192.3.1.2 255.255.255.0
  
  encapsulation frame-relay IETF
  
  bandwidth 2000
  
  clockrate 2000000
  
  frame-relay map ip 192.3.1.1 100 broadcast
  
  frame-relay intf-type dce
  
  !
  
  interface Serial1
  
  ip address 192.2.1.1 255.255.255.0
  
  no ip mroute-cache
  
  encapsulation X25 dce
  
  bandwidth 64
  
  x25 address 1234
  
  x25 htc 16
  
  x25 nvc 4
  
  x25 map ip 192.2.1.2 5678 broadcast
  
  clockrate 64000
  
  !
  
  router eigrp 10
  
  passive-interface Ethernet0
  
  network 192.3.1.0 255.255.255.0
  
  network 192.2.1.0 255.255.255.0
  
  network 192.5.1.0 255.255.255.0
  
  neighbor 192.2.1.2
  
  neighbor 192.3.1.1
  
  !
  
  no ip classless
  
  !
  
  line con 0
  
  line aux 0
  
  line vty 0 4
  
  login
  
  !
  
  end
  
   
  
   
  
  2511-2的设置
  
  Building configuration ...
  
  Current configuration:
  
  !
  
  version 11.3
  
  no service password-encryption
  
  !
  
  hostname 2511-2
  
  !
  
  enable secret 5 $1$7o5F$MSyFWzVf6JBgnjLJghHSB.
  
  !
  
  !
  
  interface Ethernet0
  
  ip address 192.2.4.1 255.255.255.0
  
  !
  
  interface Serial0
  
  ip address 192.2.1.2 255.255.255.0
  
  encapsulation x25
  
  no ip mroute-cache
  
  x25 address 5678
  
  x25 htc 16
  
  x25 nvc 4
  
  x25 map ip 192.2.1.1 1234 broadcast
  
  !
  
  interface Serial1
  
  ip address 192.2.2.1 255.255.255.0
  
  no ip mroute-cache
  
  bandwidth 2000
  
  clockrate 2000000
  
  !
  
  router igrp 10
  
  passive-interface Ethernet0
  
  network 192.2.2.0 255.255.255.0
  
  network 192.2.4.0 255.255.255.0
  
  network 192.2.1.0 255.255.255.0
  
  neighbor 192.2.1.1
  
  neighbor 192.2.2.2
  
  !
  
  ip classless
  
  !
  
  line con 0
  
  line 1 8
  
  line aux 0
  
  line vty 0 4
  
  login
  
  !
  
  end
  
   
  
   
  
  internal -1的设置
  
  Building configuration...
  
  Current configuration:
  
  !
  
  version 11.2
  
  no service udp-small-servers
  
  no service tcp-small-servers
  
  !
  
  hostname internal-1
  
  !
  
  enable secret 5 $1$cF2M$z2T8Ohij5q/yn2RsiVaGE/
  
  !
  
  !
  
  interface Ethernet0
  
  no ip address
  
  shutdown
  
  !
  
  interface Serial0
  
  ip address 192.2.2.2 255.255.255.0
  
  !
  
  interface Serial1
  
  no ip address
  
  shutdown
  
  !
  
  router eigrp 10
  
  network 192.2.2.0 255.255.255.0
  
  neighbor 192.2.2.1
  
  !
  
  no ip classless
  
  !
  
  line con 0
  
  line 1 16
  
  line aux 0
  
  line vty 0 4
  
  login
  
  !
  
  end
------分隔线----------------------------
顶一下
(3)
100%
踩一下
(0)
0%
------分隔线----------------------------
最新评论 查看所有评论
发表评论 查看所有评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 密码: 验证码:
推荐内容