返回首页

OSPF配置示例

时间:2005-12-16 来源: 作者: 点击:
后面部分提供了以下OSPF配置示例: OSPF一对多接口示例 OSPF一对多接口广播示例 OSPF一对多接口非广播示例 可变长度子网掩码示例 OSPF路由选择和路由重分配示例 路由映像示例 修改OSPF 管辖距离 按需路由选择上的OSPF示例 LSA组定步示例 阻止LSA扩散示例 忽略MOSPF LSA
  
后面部分提供了以下OSPF配置示例:
OSPF一对多接口示例
OSPF一对多接口广播示例
OSPF一对多接口非广播示例
可变长度子网掩码示例
OSPF路由选择和路由重分配示例
路由映像示例
修改OSPF 管辖距离
按需路由选择上的OSPF示例
LSA组定步示例
阻止LSA扩散示例
忽略MOSPF LSA 包示例
OSPF一对多接口示例

在图11-1,Mollie使用DLCI 201 与Neon 通信,使用DLCI 202 与Jelly通信, 使 用DLCI 203与Platty 通信。Neon 使用DLCI 101 与Mollie 通信,使用DLCI 102与Platty通信。Platty 使用DLCI 401与Neon 通信,使用DLCI 402与Mollie 通信。Jelly 使用DLCI 301与Mollie通信。

1. Mollie 的配置如下:
hostname mollie
!
interface serial 1
ip address 10.0.0.2 225.0.0.0
ip ospf network point-to-multipoint
encapsulation frame-relay
frame-relay map ip 10.0.0.1 201 broadcast
frame-relay map ip 10.0.0.3 202 broadcast
frame-relay map ip 10.0.0.4 203 broadcast
!
router ospf 1
network 10.0.0.0 0.0.0.225 area 0

2. Neon 的配置如下:
hostname neon
!
interface serial 0
ip address 10.0.0.1 225.0.0.0
ip ospf network point-to-multipoint
encapsulation frame-relay
frame-relay map ip 10.0.0.2 101 broadcast
frame-relay map ip 10.0.0.4 102 broadcast
!
router ospf 1
network 10.0.0.0 0.0.0.255 area 0

3. Platty的配置如下:
hostname platty
!
interface seria1 3
ip address 10.0.0.4 255.0.0.0
ip ospf network point-to-multipoint
encapsulation frame-relay
clock rate 1000000
frame-relay map ip 10.0.0.1 401 broadcast
frame-relay map ip 10.0.0.2 402 broadcast
!
router ospf 1
network 10.0.0.0 0.0.0.255 area 0

4. Jelly的配置如下:
hostname jelly
!
interface seria1 2
ip address 10.0.0.3 255.0.0.0
ip ospf network point-multipoint
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 10.0.0.2 301 broadcast
!
router ospf 1
network 10.0.0.0 0.0.0.255 area 0

OSPF一对多接口广播示例
下例为广播形式的一对多接口网络配置:
interface Serial 0
ip address 10.0.1.1 255.255.255.0
encapsulation frame-relay
ip ospf cost 100
ip ospf network point-to-multipoint
frame-relay map ip 10.0.1.3 202 broadcast
frame-relay map ip 10.0.1.4.203 broadcast
frame-relay map ip 10.0.1.5 204 broadcast
frame-relay local-dlci 200
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
neighbor 10.0.1.5 cost 5
neighbor 10.0.1.4 cost 10
下例显示的是10.0.1.3上的邻居配置:
interface serial 0
ip address 10.0.1.3 255.255.255.0
ip ospf network point-to-multipoint
encapsulation frame-relay
frame-relay local-dlci 301
frame-relay map ip 10.0.1.1 300 broadcast
no shut
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
上面第一个配置中的邻居的输出显示类似如下:
Router# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
4.1.1.1 1 FULL/ - 00:01:50 10.0.1.5 Serial0
3.1.1.1 1 FULL/ - 00:01:4710.0.1.4Serial0
2.1.1.1 1 FULL/ - 00:01:4510.0.1.3Serial0

上面第一个配置中的路由信息类似如下:
Router# show ip route
Codes: Connected, S-static, I-IGRP, R-RIP, M-mobile, B-BGP D-EIGRP, EX-EIGRP external, O-OSPF, IA-OSPF inter area

N1-OSPF NSSA external type 1, N2-OSPF NSSA external type 2
E1-OSPF external type 1, E2-OSPF external type 2, E-EGP i-IS-IS, L1-IS-IS level-1, L2-IS-IS level-2, *-candidate defaultU-per-user static route, o-ODR
Gateway of last resort is not set
C 1.0.0.0/8 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted,4 subnets, 2 masks
10.0.1.3/32 [110/100] via 10.0.1.3, 00:39:08, Serial0
C 10.0.1.0/24 is directly connected, Serial0
10.0.1.5/32 [110/5] via 10.0.1.5, 00:39:08, Serial0
10.0.1.4/32 [110/10] via 10.0.1.4, 00:39:08, Serial0

OSPF一对多非广播示例下例为非广播形式的一对多网络配置: interface Serial0

OSPF一对多非广播示例下例
为非广播形式的一对多网络配置:
interface Serial0

ip address 10.0.1.1 255.255.255.0
ip ospf network point-to-multipointnon-broadcast
encapsulation frame-relay

no keepalive
frame-relay local-dlci 200
frame-relay map ip 10.0.1.3 202
frame-relay map ip 10.0.1.4 203
frame-relay map ip 10.0.1.5 204
no shut

!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
neighbor 10.0.1.3 cost 5
neighbor 10.0.1.4 cost 10
neighbor 10.0.1.5.cost 15

下例是另一端路由器上的配置:

interface Serial9/2
ip address 10.0.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast

no ip mroute-cache
no keepalive
no fair-queue
frame-relay local-dlci 301
frame-relay map ip 10.0.1.1 300

no shut
!
router ospf 1
network 10.0.1.0
0.0.0.255 area 0

上面第一个配置中的邻居的输出显示类似如下:
Router# show ip ospf neighbor

Neighbor IDPri State Dead TimeAddressInterface
4.1.1.1 1 FULL/ - 00:01:5210.0.1.5 Serial0
3.1.1.1 1 FULL/ -00:01:5210.0.1.4Serial0
2.1.1.1 1 FULL/ -00:01:5210.0.1.3Serial0

可变长度子网掩码示例
OSPF、静态路由和IS-IS支持可变长度子网掩码(VLSM),因而可在不同接口上对同一网络编号使用不同掩码,保存IP地址,更有效地利用有效地址空间。

以下示例,使用30位子网掩码,2位用来保留串行主机地址, 有足够的主机地址空间提供给点对点串行链路上的主机两端点。
interface ethernet0
ip address 131.107.1.1 255.255.255.0
!8 bits of host address space reserved for ethernets

interface serial 0
ip address 131.107.254.1 255.255.255.252
! 2 bits of host address space reserved for serial lines

! Router is configured for OSPF and assigned AS 107
router ospf 107
! Specifies network directly connnected to the router
network 131.107.0.0 0.0.255.255 area 0.0.0.0

OSPF路由选择和路由重分配示例
OSPF的特色之一就是在许多内部路由器、区域边界路由器和自治系统边界路由器之 间取得协调。缺省参数值、无认证和分配区域的接口成为OSPF路由器的最低配置。

下表中的三个例子说明了特定情况的配置:
例一说明了基本OSPF命令的简单设置

例二阐述了在单一性的强制指派OSPF自治系统内,
对内部路由器、区域边界路由器(ABR)和自治系统边界路由器(ASBR)所进行的设置。

例三是一个较复杂的设置,说明了运用不同工具来控制OSPF路由选择环境。
1. 基本OSPF配置示例
下面的例子是一个简单的OSPF设置,激活OSPF路由选择进程9000,将以太网0连接到区域0.0.0.0,并重分配RIP到OSPF,重分配OSPF到RIP。

interface ethernet 0
ip address 130.93.1.1 255.255.255.0
ip ospf cost 1
!

interface ethernet 1
ip address 13.94.1.1 255.255.255.0
!

router ospf 9000
network 130.93.0.0 0.0.255.255 area 0.0.0.0
redistribute rip metric 1 subnets
!

router rip
network 130.94.0.0
redistribute ospf 9000
default-metric 1

2. 对内部路由器、ABR和ASBR做基本OSPF配置的例子
下面的例子说明将四个区域ID分配给四个IP地址范围。在这个例子中,初始化OSPF路由选择进程109,定义四个OSPF区域:10.9.50.0,2,3和0。区域10.9.50.0,2和3屏蔽特定的地址范围,而区域0为其他所有网络激活OSPF。

router ospf 109
network 131.108.20.0 0.0.0.255 area 10.9.50.0
network 131.108.0.0 0.0.255.255 area 2
network 131.109.10.0 0.0.0.255 area 3
network 0.0.0.0 255.255.255.255 area 0
!
! Interface Ethernet0 is in area 10.9.50.0:
interface ethernet 0

!
! Interface Ethernet0 is in area 10.9.50.0:
interface ethernet 0
ip address 131.108.20.5 255.255.255.0
!

! Interface Ethernet 1 is in area 2:
interface ethernet 1
ip address 131.108.1.5 255.255.255.0
!

!Interface Ethernet2 is in area 2:
interface ethernet2
ip address 131.108.2.5 255.255.255.0
!

!Interface Ethernet3 is in area 3:
interface ethernet 3
ip address 131.109.10.5 255.255.255.0
!

!Interface Ethernet4 is in area 0:
interface ethernet 4
ip address 131.109.1.1 255.255.255.0
!

!Interface Ethernet5 is in area 0:
interface ethernet 5
ip address 10.1.0.1 255.255.0.0

继续评估每个network路由器配置命令,因此配置中这些命令的顺序是重要的。Cisco IOS软件继续为每个接口评估address/widcard-mask对,详细信息请参看第十二章。

考虑第一个network area命令。区域ID 10.9.50.0设置给接口,子网131.108.20.0在此接口上定位。假定接口以太网0已匹配确认,接口以太网0连接到区域10.9.50.0。

接着评估第二个network area命令。对区域2,同样的进程运用到所有接口(除接口以太网0外)。假定接口以太网1已匹配确认,然后对此接口激活OSPF,以太网1连接到区域2。

对所有network area命令,继续将接口连接到OSPF区域过程。注意例子中最后一个network area命令是特殊情况。通过此命令,所有可用接口(未明确连接到其他区域)连接到区域0。

3. 复杂的内部路由器、ABR和ASBR例子
下面的例子简述了在单一性OSPF自治系统内,配置几个路由器。图11-4提供了说明这个配置例子的总体网络图。
在OSPF自治系统109内设置5个路由器:
路由器A和路由器B都是区域1内的内部路由器。

路由器C是OSPF区域边界路由器。注意对路由器C,区域1被分配给E3A,区域1被分配给E3,区域0被分配给S0。

路由器D是区域0 (主干区域)内的内部路由器。在这个例子里,两个network路由器配置命令指定同一区域(区域0为主干区域)。

路由器E是OSPF自治系统边界路由器。注意BGP路由被重分配到OSPF,OSPF通告这些路由。

注意:在配置自治系统中的全部路由器时,不必定义OSPF自治系统里的所有区域,只须 定义直接相连区域。在接下来的例子中,当区域边界路由器(路由器C) 将汇总链路状态 通告插入到区域1里时,区域1的路由器(路由器A和B)接收区域0中的路由。

自治系统109通过IP地址11.0.0.6到外部对等系统的BGP链路连接到外部。


图11-4 样本OSPF自治系统网络图

(1)路由器A—内部路由器
interface ethernet 1
ip address 131.108.1.1 255.255.255.0

router ospf 109
network 131.108.0.0 0.0.255.255 area 1

(2)路由器B—内部路由器
interfcae ethernet 2
ip address 131.108.1.2 255.255.255.0

router ospf 109
network 131.108.0.0 0.0.255.255 area 1

(3)路由器C—ABR
interface ethernet 3
ip address 131.108.1.3 255.255.255.0
nterface serial 0
ip address 131.108.2.3 255.255.255.0
router ospf 109
network 131.108.1.0 0.0.0.255 area 1
network 131.108.2.0 0.0.0.255 area 0


(4)路由器D—内部路由器
interface ethernet 4
ip address 10.0.0.4 255.0.0.0

interface serial 1
ip address 131.108.2.4 255.255.255.0

router ospf 109
network 131.108.2.0 0.0.0.255 area 0
network 10.0.0.0 0.255.255.255 area 0

(5)路由器E—ASBR
interface ethernet 5
ip address 10.0.0.5 255.0.0.0

interface serial 2
ip address 11.0.0.5 255.0.0.0

router ospf 109
network 10.0.0.0 0.255.255.255 area 0
redistribute bgp 109 metric 1 metric-type 1

router bgp 109
network 131.108.0.0
network 10.0.0.0
neighbor 11.0.0.6 remote-as 110

4. ABR复杂OSPF配置例子
下面的例子完成了对ABR的任务建立。这些任务分成下列两大类:
基本OSPF配置

路由器分配
这个例子中的设置将在后面的说明中予以解释。
图11-5说明了网络地址范围以及对 接口的区域分配。


图11-5 OSPF配置示例的接口和区域说明


例子中的基本配置任务如下:
为以太网0~3接口配置地址范围
使每个接口的OSPF
为每个区域和网络设立OSPF认证密钥
分配链路状态尺度和设置其他OSPF接口配置选项
创立区域ID为36.0.0.0的stub区域(注意:尽管area路由器配置命令的authentication 和stub选项可通过独立的area命令项来指定,但仍可合并为一个area命令)。

指定主干区域(区域0)。
与重分配相关的配置任务如下
通过选项设置(包括metric-type,metric,tag和subnet),将IGRP和RIP重分配到OSPF。
将IGRP和OSPF重分配到RIP。
下面是OSPF配置的例子
interface ethernet 0
ip address 192.42.110.201 255.255.255.0
ip ospf authentication-key abcdefgh
ip ospf cost 10
!

interface ethernet 1
ip address 131.119.251.201 225.255.255.0
ip ospf authentication-key ijklmnop

ip ospf cost 20
ip ospf retransmit-interval 10
ip ospf transmit-delay 2
ip ospf priority 4
!



interface ethernet 2
ip address 131.119.254.201 255.255.255.0
ip ospf authentication-key abcdefgh
ip ospf cost 10
!

interface ethernet 3
ip address 36.56.0.201 255.255.0.0
ip ospf authentication-key ijklmnop

ip ospf cost 20
ip ospf dead-interval 80

OSPF 在网络131.119.0.0上:
router ospf 201
network 36.0.0.0 0.255.255.255 area 36.0.0.0
network 192.42.110.0 0.0.0.255 area 192.42.110.0
network 131.119.0.0 0.0.255.255 area 0

area 0 authentication
area 36.0.0.0 stub
area 36.0.0.0 authentication
area 36.0.0.0 default-cost 20
area 192.42.110.0 authentication
area 36.0.0.0 range 36.0.0.0 255.0.0.0
area 192.42.110.0 range 192.42.110.0 255.255.255.0
area 0 range 131.119.251.0 255.255.255.0
area 0 range 131.119.254.0 255.255.255.0

redistribute igrp 200 metric-type 2 metric 1 tag 200 subnets
redistribute rip metric-type 2 metric 1 tag 200
IGRP自治系统200在131.119.0.0上:
router igrp 200
network 131.119.0.0!
!RIP for 192.42.110!
router rip
network 192.42.110.0
redistribute igrp 200 metric 1
redistribute ospf 201 metric 1

路由映像示例
这部分的例子说明如何使用有或没有路由映像的重分配,IP和CLNS路由选择协议 的例子都列在其中:
下面的例子
将所有OSPF重分配到IGRP:
router igrp 109
redistribute ospf 110
下面的例子将跳数为1的RIP路由器分配到OSPF,这些路由的尺度为5,尺度类型为1型,标识等于1,作为外部链路状态广告(LSA)重分配到OSPF:
router ospf 109
redistribute rip route-map rip-to-ospf
!
router-map rip-to-ospf permit
match metric 1
set metric 5
set metric-type type1
set tag 1

在下面的例子中,将OSPF以tag7获取的路由作为RIP尺度15重分配:

router rip
redistribute ospf 109 route-map 5

!
route-map 5 permit
match tag 7
set metric 15
在下面的例子中,将下一跳路由器在串行接口0上的OSPF区域内和区域间路由重分配到INTER_AS尺度为5的BGP:

router bgp 109
redistribute ospf 109
route-map 10
!

route-map 10 permit
match route-type internal
match interface serial 0
et metric 5

下面的例子将两类路由重分配到综合IS-IS路由选择表(支持IP和CLNS), 第一类路 由是tag 5的OSPF外部IP路由,这些路由以尺度5插入2级IS-IS LSP;第二类是ISO-IGRP,来自CLNS报头路由并与CLNS访问表2000匹配,它们将作为2级LSP以尺度30重分配到 IS-IS。

router isis redistribute ospf 109 route-map 2 redistribute iso-igrp nsfnet route-map 3!route-map 2 permit match route-type external match tag 5 set metric set level level-2

router isis
redistribute ospf 109 route-map 2
redistribute iso-igrp nsfnet route-map 3
!
route-map 2 permit
match route-type external
match tag 5 set metric
set level level-2

!
route-map 3 permit
match address 2000
set metric 30

tage 1,2,3和5的OSPF外部路由分别以尺度1,1,5和5重分配到RIP,tag为4的OSPF路由不重分配:
router rip
redistribute ospf 109 route-map 1
!

route-map 1 permit
match tag 1 2
set metric 1
!

route-map 1 permit
match tag 3
set metric 5
!

route-map 1 deny
match tag 4
!

route map 1
permit match tag 5
set metric 5

如果有到网络140.222.0.0的OSPF路由,就产生尺度为1的缺省网络0.0.0.0到RIP, 配置如下:

router rip
redistribute ospf 109 route-map default
!

route-map default permit
match ip address 1
set metric 1
!

access-list 1 permit 140.222.0.0 0.0.255.255
access-list 2 permit 0.0.0.0 0.0.0.0

在下面的配置中,为网络160.89.0.0获取路由的RIP以及以报头49.0001.0002获取路由的ISO-IGRP,将以尺度5重分配为IS-IS 2级LSP:
router isis
redistribute rip route-map 1
redistribute iso-igrp remote route-map 1
!

route map 1 permit
match ip address 1
match clns address 2
set metric 5
set level level-2

!
access-list 1 permit 160.89.0.0 0.0.255.255
clns filter-set 2 permit 49.0001.0002…

  下面的便子说明路映像如何被default-configuration路由器配置命令引用,这被称为条件缺省源(conditional defualt origination).OSPF将产生缺省路由(网络 0.0.0.0),基于140.222.0.0上2型尺度为5网络0.0.0.0 在路由选择表中。
route-map ospf-default permit
match ip address 1
set metric 5
set metri-type type-2
!
access-list 1 140.222.0.0 0.0.255.255
!
router ospf 109
default-information originate router-map ospf-default

修改OSPF 管辖距离示例
下例将外部距离修改为200,使其几乎不可信。如图11-6所示。路由器A
router ospf 1
redistribue ospf2 subnet
distance ospf external 200
!
router ospf 2
redistribute ospf subnet
distance ospf external 200

路由器B
router ospf 1
redistribute ospf 2 subnet
distance ospf external 200
!

router ospf 2
redistribute ospf 1 subnet
distance ospf external 200

按需路由选择上的OSPF示例
下面是按需要电路OSPF的配置,如图11-7所示。注意,按需要电路只定义在一边(路由器A上的BR10)。不需要要两边都配置。

图11-7 按需电路上的OSPF
路由器A
username RouterB password 7 060C1A2F47
isdn switch-type basic-5ess
ip routing

!
interface TokenRing0
ip address 140.10.20.7 255.255.255.0
no shut
!

interface BRI0
no cdp enable description connected PBX 1485
ip address 140.10.10.7 255.255.255.0
encapsulation ppp
ip ospf demand-circuit
dialer map ip 140.10.10.6 name RouterB broadcast 61484
dialer-group 1
ppp authentication chap
no shut
!
router ospf 100
network 140.10.10.0 0.0.0.255 area 0
network 140.10.20.0 0.0.0.255 area 0
!
dialer-list 1 protocol ip permit

路由器B
username RouterA password 7 04511E0804
isdn switch-type basic-5ess
ip routing
!
interface Ethernet0
ip address 140.10.60.6 255.255.255.0

no shut
!
interface BRI0
no cdp enable
description connected PBX 1484
ip address 140.10.10.6 255.255.255.0
encapsulation ppp
dialer map ip 140.10.10.7 name RouterA broadcast 61485
dialer-group 1
ppp authentication chap
no shut

!
router ospf 100
network 140.10.10.0 0.0.0.255 area 0
network 140.10.60.0 0.0.0.255 area 0
!
dialer-list 1 protocol ip permitL
SA组定步示例

下面将OSPF LSA 组定步修改为60秒:
router ospf

timers lsa-group-pacing 60
阻止LSA扩散示例

下例配置阻止OSPF LSA通过以太网口扩散到广播、非广播或点对点的可达网络。

interface ethernet 0
ospf database-filter all out
下例配置阻止OSPF LSA通过IP地址为1.2.3.4的邻居扩散到一对多的网络。
router ospf 109
neighbor 1.2.3.4 database-filter all out

忽略MOSPF LSA 包示例
下例配置路由器使其在接收MOSPF 信息包时抑制发送系统注册信息。
router ospf 109
ospf ignore lsa mospf

------分隔线----------------------------
顶一下
(1)
100%
踩一下
(0)
0%
------分隔线----------------------------
最新评论 查看所有评论
发表评论 查看所有评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 密码: 验证码:
推荐内容