返回首页

IGRP路由协议基本配置

时间:2005-01-14 来源: 作者: 点击:
IGRP协议 IGRP (Interior Gateway Routing Protocol)是一种动态距离向量路由协议,它由Cisco公司八十年代中期设计。使用组合用户配置尺度,包括延迟、带宽、可靠性和负载。 缺省情况下,IGRP每90秒发送一次路由更新广播,在3个更新周期内(即270秒),没有从路由中的第一
  IGRP协议

  IGRP (Interior Gateway Routing Protocol)是一种动态距离向量路由协议,它由Cisco公司八十年代中期设计。使用组合用户配置尺度,包括延迟、带宽、可靠性和负载。

缺省情况下,IGRP每90秒发送一次路由更新广播,在3个更新周期内(即270秒),没有从路由中的第一个路由器接收到更新,则宣布路由不可访问。在7个更新周期即630秒后,Cisco IOS 软件从路由表中清除路由。

1. 有关命令

任务

命令

指定使用 RIP协议

router igrp autonomous-system 1

指定与该路由器相连的网络

network network

指定与该路由器相邻的节点地址

neighbor ip-address


注:1、autonomous-system可以随意建立,并非实际意义上的autonomous-system,但运行IGRP的路由器要想交换路由更新信息其autonomous-system需相同。

2.举例


Router1:

router igrp 200

network 192.200.10.0

network 192.20.10.0

!

1. 启动IGRP路由协议,在全局设置模式下;

router igrp 自治域号

同一自治域内的路由器才能交换路由信息。

2. 本路由器参加动态路由的子网;

net work 子网号

IGRP只是将由net work指定的子网在各端口中进行传送以交换路由信息,如果不指定子网,则路由器不会将该子网广播给其它路由器。

3. 指定某路由器所知的IGRP路由信息广播给那些与其相邻接的路由器;

neighbor 邻接路由器的相邻端口IP地址。

IGRP是一个广播型协议,为了使IGRP路由信息能在非广播型网络中传输,必须使用该设置,以允许路由器间在非广播型网络中交换路由信息,广播型网络如以太网无须设置此项。以上为IGRP的基本设置,通过该设置,路由器已能完全通过IGRP进行路由信息交换其他设置。

4. 不允许某个端口发送IGRP路由信息

passive-interface 端口号

一般地,在以太网上只有一台路由器时,IGRP广播没有任何意义,且浪费带宽,完全可以将其过滤掉。

5. 负载平衡设置

IGRP可以在两个进行IP通信的设备间同时启用四条线路,且任何一条路径断掉都不会影响其它路径的传输。

当两条路径或多条路径的metric相同或在一定的范围内,就可以启动平衡功能。

1. 设置是否使用负载平衡功能。

traffic-share balanced 或min

balanced 表示启用负载平衡min表示不启用负载平衡, 只走最优路径。

2 . 设置路径间的metric相差多大时,可以在路径间启用负载平衡。

variance metric 差值

缺省值为1,表示只有两条路径metric相同时才能在两条路径上启用负载平衡。

实例:

2511-1的设置

Current configuration:

version 11.3

no service password-encryption

!

hostname 2511-1

!

enable password cisco

!

!

interface Ethernet0

ip address 192.4.1.1 255.255.255.0

!

interface Serial0

ip address 192.3.1.1 255.255.255.0

encapsulation frame-relay IETF

no ip mroute-cache

bandwidth 2000

frame-relay map ip 192.3.1.2 100 broadcast

frame-relay lmi-type cisco

!

interface Serial1

ip address 192.1.1.1 255.255.255.0

encapsulation ppp

bandwidth 64

!

router igrp 10

passive-interface Ethernet0

network 192.1.1.0 255.255.255.0

network 192.3.1.0 255.255.255.0

network 192.4.1.0 255.255.255.0

neighbor 192.1.1.2

neighbor 192.3.1.2

!

ip classless

!

line con 0

line 1 8

line aux 0

line vty 0 4

!

end

2505的设置

Current configuration:

!

version 11.2

no service udp-small-servers

no service tcp-small-servers

!

hostname 2505

!

enable secret 5 $1$GbYT$OR05giiLZxl4hEAO0F8kV1

!

!

hub ether 0 1

link-test

auto-polarity

!

hub ether 0 2

link-test

auto-polarity

!

hub ether 0 3

link-test

auto-polarity

!

hub ether 0 4

link-test

auto-polarity

!

hub ether 0 5

link-test

auto-polarity

!

hub ether 0 6

link-test

auto-polarity

!

hub ether 0 7

link-test

auto-polarity

!

hub ether 0 8

link-test

auto-polarity

!

interface Ethernet0

ip address 192.1.4.1 255.255.255.0

!

interface Serial0

ip address 192.1.2.1 255.255.255.0

bandwidth 2000

clockrate 2000000

!

interface Serial1

ip address 192.1.1.2 255.255.255.0

enpsuration ppp

bandwidth 64

clockrate 64000

!

router igrp 10

passive-interface Ethernet0

network 192.1.1.0 255.255.255.0

network 192.1.2.0 255.255.255.0

network 192.1.4.0 255.255.255.0

neighbor 192.1.1.1

neighbor 192.1.2.2

!

no ip classless

!

line con 0

line aux 0

line vty 0 4

login

!

end

internal-2的设置

Current configuration :

!

!

version 11.2

no service udp-small-servers

no service tcp-small-servers

!

hostname internal-2

!

enable secret 5 $1$KX00$rTI/2TvDokWxT4xC6wvmi/

!

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

ip address 192.1.2.2 255.255.255.0

!

interface Serial1

no ip address

shutdown

!

router igrp 10

network 192.1.2.0 255.255.255.0

neighbor 192.1.2.1

!

no ip classless

!

line con 0

line 1 16

line aux 0

line vty 0 4

login

!

end

2514的设置

Current configuration :

!

!

version 11.2

no service udp-small-servers

no service tcp-small-servers

!

hostname 2514

!

enable secret 5 $1$uoHU$Vks/lY CRi33z4TXs4qekI0

!

frame-relay switching

!

interface Ethernet0

ip address 192.5.1.1 255.255.255.0

!

interface Ethernet1

no ip address

shutdown

!

interface Serial0

ip address 192.3.1.2 255.255.255.0

encapsulation frame-relay IETF

bandwidth 2000

clockrate 2000000

frame-relay map ip 192.3.1.1 100 broadcast

frame-relay intf-type dce

!

interface Serial1

ip address 192.2.1.1 255.255.255.0

no ip mroute-cache

encapsulation X25 dce

bandwidth 64

x25 address 1234

x25 htc 16

x25 nvc 4

x25 map ip 192.2.1.2 5678 broadcast

clockrate 64000

!

router igrp 10

passive-interfce Ethernet0

network 192.3.1.0 255.255.255.0

network 192.2.1.0 255.255.255.0

network 192.5.1.0 255.255.255.0

neighbor 192.2.1.2

neighbor 192.3.1.1

!

no ip classless

!

line con 0

line aux 0

line vty 0 4

login

!

end

2511-2的设置

Building configuration…

Current configuration:

version 11.3

no service password-encryption

!

hostname 2511-2

!

enable secret 5 $1$7o5F$MSyFWzVf6JBgnjLJghHSB.

!

interface Ethernet0

ip address 192.2.4.1 255.255.255.0

!

interface Serial0

ip address 192.2.1.2 255.255.255.0

encapsulation x25

no ip mroute-cache

x25 address 5678

x25 htc 16

x25 nvc 4

x25 map ip 192.2.1.1 1234 broadcast

!

interface Serial1

ip address 192.2.2.1 255.255.255.0

no ip mroute-cache

bandwidth 2000

clockrate 2000000

!

router igrp 10

network 192.2.2.0 255.255.255.0

network 192.2.4.0 255.255.255.0

network 192.2.1.0 255.255.255.0

neighbor 192.2.1.1

neighbor 192.2.2.2

!

ip classless

!

line con 0

line 1 8

line aux 0

line vty 0 4

login

!

end

internal -1的设置

Building configuration…

Current configuration:

version 11.2

no service udp-small-servers

no service tcp-small-servers

!

hostname internal-1

!

enable secret 5 $1$cF2M$z2T8Ohij5q/yn2RsiVaGE/

!

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

ip address 192.2.2.2 255.255.255.0

!

interface Serial1

no ip address

shutdown

!

router igrp 10

network 192.2.2.0 255.255.255.0

neighbor 192.2.2.1

!

no ip classless

!

line con 0

line 1 16

line aux 0

line vty 0 4

login

!

end

------分隔线----------------------------
顶一下
(0)
0%
踩一下
(0)
0%
------分隔线----------------------------
最新评论 查看所有评论
发表评论 查看所有评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 密码: 验证码:
推荐内容